Связаться с нами

  • (097) ?601-88-87
    (067) ?493-44-27
    (096) ?830-00-01

Статьи

Чи можливо включити застарілі розширення в Firefox?

  1. Чи можливо включити застарілі розширення в Firefox? Якщо ви до останнього моменту перебували в щасливому...
  2. Застарілі розширення можна включити в Firefox Nightly і Developer Edition?
  3. Що ж робити зараз?
  4. схоже
  5. Чи не оновлюйтеся або використовуйте стару версію Firefox
  6. Застарілі розширення можна включити в Firefox Nightly і Developer Edition?
  7. Що ж робити зараз?
  8. схоже
  9. Чи не оновлюйтеся або використовуйте стару версію Firefox
  10. Застарілі розширення можна включити в Firefox Nightly і Developer Edition?
  11. Що ж робити зараз?

Чи можливо включити застарілі розширення в Firefox?

Якщо ви до останнього моменту перебували в щасливому невіданні про те, що з Firefox 57 Mozilla відключить всі застарілі розширення, то радість оновлення до широко розрекламованого Firefox Quantum у вас швидко могла зійти нанівець.

Див. також: як відновити відключені розширення в старих версіях Firefox (рішення масової проблеми з доповненнями Firefox, яка виникла у користувачів починаючи з травня 2019).

Зрозумівши, що щось не так і заглянувши в менеджер розширень, ви побачите: всіх або багатьох з ваших модулів там більше просто немає. Замість них красується напис: «Щось відсутня? Деякі розширення більше не підтримуються Firefox ».

Клік по посиланню «показати застарілі розширення» відобразить те, що у вас було, але включити розширення не вийде.

Як бачите, у нас список важкий. Сюди тільки з відомих потрапили Tab Mix Plus, Менеджер сесій, FindBar Tweak, FireGestures, Location Bar Enhancer, Tab Groups, Thumbnail Zoom Plus і завантажувач музики VK Universal Downloader. Це лише наші втрати. На практиці Firefox втратив тисячі доповнень.

Користувачеві пропонується або видалити підтримуються розширення або ж «знайти заміну». Зрідка цей механізм спрацьовує.

Наприклад, для Thumbnail Zoom Plus він видає цілком прийнятну альтернативу у вигляді Imagus. Однак набагато частіше видається або щось зовсім невідповідний, або загальний список розширень.

На жаль, включити застарілі розширення в Firefox 57 або вище не можна. Вибір у користувача залишається вельми скромний.

Чи не оновлюйтеся або використовуйте стару версію Firefox

  • Якщо ви ще не оновилися на версію 57 і вище: вимкніть оновлення в налаштуваннях браузера;

Якщо ви ще не оновилися на версію 57 і вище: вимкніть оновлення в налаштуваннях браузера;

  • Якщо оновлення вже сталося, то скачайте і встановіть в іншу папку попередню версію 56 і відразу ж вимкніть в ній автоапдейт;
  • Також можна залишитися на версіях Firefox 52, що відносяться до ESR. Це версії з розширений терміном підтримки. Відключати оновлення тут не потрібно.

ESR збірки примітні тим, що розробники будуть виправляти в них баги і закривати уразливості значно довше, ніж для FF 56 і будь-який інший не ESR-редакції браузера.

Тобто залишатися на Firefox 52 ESR краще, з точки зору безпеки, ніж на 56. Однак є і неприємний момент: з перенесенням профілю FF 56-57 на будь-яку версію молодше 55 можуть виникнути проблеми. Про це Mozilla попереджала безпосередньо під час виходу Firefox 55:

Так що, якщо у вас багато цінної інформації, можливо, краще не ризикувати з переходом на ESR. Якщо ж безпеку вам дорожче, і ви віддасте перевагу в результаті Firefox 52 ESR, то для цієї версії перед першим запуском браузера можна створити новий профіль.

Використовуйте offline-інсталятор для установки нової копії Firefox в окрему папку і не забудьте зняти там опцію, щоб «вогненний лис" не запустився автоматично після інсталяції. Інакше він підхопить ваш поточний профіль. Коли установка буде завершена додайте до з'явився ярлику «-p -no-remote»:

Коли установка буде завершена додайте до з'явився ярлику «-p -no-remote»:

Тоді при кліці по іконці замість запуску браузера спершу стартує менеджер, де і можна буде створити новий окремий профіль для версії 52 ESR. Пізніше ви будете вибирати його кожен раз при кліці по цьому ярлику Firefox.

Застарілі розширення можна включити в Firefox Nightly і Developer Edition?

Намагаючись знайти рішення своєї проблеми, в мережі ви, швидше за все, знайдете інформацію про те, що старі розширення все-таки можна включити в Firefox Nightly і Developer Edition (нестабільні тестові версії браузера). Для цього, мовляв, всього лише треба зайти на спеціальну сторінку about: config і подвійним кліком перевести там параметр extensions.legacy.enabled в значення true.

Втім, не поспішайте радіти чи тим більше вже переходити зі стабільних на тестові, проблемні збірки. Ми перевірили цей спосіб на великій групі розширень і з усього, що ми тестували заробив лише Select like a Boss - крихітне розширення для виділення тексту посеред посилань. Його в нових версіях і так можна замінити на Drag-Select Link Text.

Все інше начебто і включилося, але більшість модулів просто не працювало. Ніяк. У свою чергу, Tab Mix Plus після включення приховав за замовчуванням кнопку створення нової вкладки до того ж зробив неможливим перемикання між табами. Його ми тут же відключили. Можливо, з'явилися й інші проблеми, але далі дивитися ми просто не стали.

Можливо, з'явилися й інші проблеми, але далі дивитися ми просто не стали

До слова, сам параметр extensions.legacy.enabled є і в стабільній версії програми, але, зрозуміло, тут він теж не допомагає.

Ще раз пояснимо: проблема застарілих розширень пов'язана саме з движком браузера, який разюче оновився з виходом версії 57. Ніяких простих рішень щодо їхнього включення тут, на превеликий жаль, точно не буде. У майбутньому такого відбуватися вже не має, так як у Firefox тепер залишаються тільки слабо залежні від зміни версій розширення WebExtension.

Що ж робити зараз?

Шукати альтернативи і ... чекати. Багато з авторів розширень встигли перевести їх на нові «рейки» лише зовсім незадовго до виходу Firefox Quantum . Це стосується, наприклад, Adblock Plus і Greasemonkey. Інші ж розробники ще тільки почали свою роботу.

Наприклад, автори вищезгаданого Tab Mix Plus зараз збирають відгуки про те, які з колишніх функцій в першу чергу реалізовувати в новій (ще не випущеної) версії розширення, яка була б сумісна з Firefox Quantum. Роблять вони це тому що їм доведеться заново написати модуль, який містить десятки тисяч рядків коду.

Безумовно, буде багато і тих розширень, що не перероблять під новий Firefox вже ніколи. Тут лише залишається шукати заміну в наповнюють зараз заново каталозі Mozilla або чекати, коли вона з'явиться, залишаючись на одній з колишніх версій браузера.

Ігор Андрєєв - автор статей для ITRew.ru і Our-Firefox.ru. Захоплений сучасними технологіями, розповідаю про них у своїх текстах)

Сторінка автора - twitter.com

схоже

Чи можливо включити застарілі розширення в Firefox?

Якщо ви до останнього моменту перебували в щасливому невіданні про те, що з Firefox 57 Mozilla відключить всі застарілі розширення, то радість оновлення до широко розрекламованого Firefox Quantum у вас швидко могла зійти нанівець.

Див. також: як відновити відключені розширення в старих версіях Firefox (рішення масової проблеми з доповненнями Firefox, яка виникла у користувачів починаючи з травня 2019).

Зрозумівши, що щось не так і заглянувши в менеджер розширень, ви побачите: всіх або багатьох з ваших модулів там більше просто немає. Замість них красується напис: «Щось відсутня? Деякі розширення більше не підтримуються Firefox ».

Клік по посиланню «показати застарілі розширення» відобразить те, що у вас було, але включити розширення не вийде.

Як бачите, у нас список важкий. Сюди тільки з відомих потрапили Tab Mix Plus, Менеджер сесій, FindBar Tweak, FireGestures, Location Bar Enhancer, Tab Groups, Thumbnail Zoom Plus і завантажувач музики VK Universal Downloader. Це лише наші втрати. На практиці Firefox втратив тисячі доповнень.

Користувачеві пропонується або видалити підтримуються розширення або ж «знайти заміну». Зрідка цей механізм спрацьовує.

Наприклад, для Thumbnail Zoom Plus він видає цілком прийнятну альтернативу у вигляді Imagus. Однак набагато частіше видається або щось зовсім невідповідний, або загальний список розширень.

На жаль, включити застарілі розширення в Firefox 57 або вище не можна. Вибір у користувача залишається вельми скромний.

Чи не оновлюйтеся або використовуйте стару версію Firefox

  • Якщо ви ще не оновилися на версію 57 і вище: вимкніть оновлення в налаштуваннях браузера;

Якщо ви ще не оновилися на версію 57 і вище: вимкніть оновлення в налаштуваннях браузера;

  • Якщо оновлення вже сталося, то скачайте і встановіть в іншу папку попередню версію 56 і відразу ж вимкніть в ній автоапдейт;
  • Також можна залишитися на версіях Firefox 52, що відносяться до ESR. Це версії з розширений терміном підтримки. Відключати оновлення тут не потрібно.

ESR збірки примітні тим, що розробники будуть виправляти в них баги і закривати уразливості значно довше, ніж для FF 56 і будь-який інший не ESR-редакції браузера.

Тобто залишатися на Firefox 52 ESR краще, з точки зору безпеки, ніж на 56. Однак є і неприємний момент: з перенесенням профілю FF 56-57 на будь-яку версію молодше 55 можуть виникнути проблеми. Про це Mozilla попереджала безпосередньо під час виходу Firefox 55:

Так що, якщо у вас багато цінної інформації, можливо, краще не ризикувати з переходом на ESR. Якщо ж безпеку вам дорожче, і ви віддасте перевагу в результаті Firefox 52 ESR, то для цієї версії перед першим запуском браузера можна створити новий профіль.

Використовуйте offline-інсталятор для установки нової копії Firefox в окрему папку і не забудьте зняти там опцію, щоб «вогненний лис" не запустився автоматично після інсталяції. Інакше він підхопить ваш поточний профіль. Коли установка буде завершена додайте до з'явився ярлику «-p -no-remote»:

Коли установка буде завершена додайте до з'явився ярлику «-p -no-remote»:

Тоді при кліці по іконці замість запуску браузера спершу стартує менеджер, де і можна буде створити новий окремий профіль для версії 52 ESR. Пізніше ви будете вибирати його кожен раз при кліці по цьому ярлику Firefox.

Застарілі розширення можна включити в Firefox Nightly і Developer Edition?

Намагаючись знайти рішення своєї проблеми, в мережі ви, швидше за все, знайдете інформацію про те, що старі розширення все-таки можна включити в Firefox Nightly і Developer Edition (нестабільні тестові версії браузера). Для цього, мовляв, всього лише треба зайти на спеціальну сторінку about: config і подвійним кліком перевести там параметр extensions.legacy.enabled в значення true.

Втім, не поспішайте радіти чи тим більше вже переходити зі стабільних на тестові, проблемні збірки. Ми перевірили цей спосіб на великій групі розширень і з усього, що ми тестували заробив лише Select like a Boss - крихітне розширення для виділення тексту посеред посилань. Його в нових версіях і так можна замінити на Drag-Select Link Text.

Все інше начебто і включилося, але більшість модулів просто не працювало. Ніяк. У свою чергу, Tab Mix Plus після включення приховав за замовчуванням кнопку створення нової вкладки до того ж зробив неможливим перемикання між табами. Його ми тут же відключили. Можливо, з'явилися й інші проблеми, але далі дивитися ми просто не стали.

Можливо, з'явилися й інші проблеми, але далі дивитися ми просто не стали

До слова, сам параметр extensions.legacy.enabled є і в стабільній версії програми, але, зрозуміло, тут він теж не допомагає.

Ще раз пояснимо: проблема застарілих розширень пов'язана саме з движком браузера, який разюче оновився з виходом версії 57. Ніяких простих рішень щодо їхнього включення тут, на превеликий жаль, точно не буде. У майбутньому такого відбуватися вже не має, так як у Firefox тепер залишаються тільки слабо залежні від зміни версій розширення WebExtension.

Що ж робити зараз?

Шукати альтернативи і ... чекати. Багато з авторів розширень встигли перевести їх на нові «рейки» лише зовсім незадовго до виходу Firefox Quantum . Це стосується, наприклад, Adblock Plus і Greasemonkey. Інші ж розробники ще тільки почали свою роботу.

Наприклад, автори вищезгаданого Tab Mix Plus зараз збирають відгуки про те, які з колишніх функцій в першу чергу реалізовувати в новій (ще не випущеної) версії розширення, яка була б сумісна з Firefox Quantum. Роблять вони це тому що їм доведеться заново написати модуль, який містить десятки тисяч рядків коду.

Безумовно, буде багато і тих розширень, що не перероблять під новий Firefox вже ніколи. Тут лише залишається шукати заміну в наповнюють зараз заново каталозі Mozilla або чекати, коли вона з'явиться, залишаючись на одній з колишніх версій браузера.

Ігор Андрєєв - автор статей для ITRew.ru і Our-Firefox.ru. Захоплений сучасними технологіями, розповідаю про них у своїх текстах)

Сторінка автора - twitter.com

схоже

Чи можливо включити застарілі розширення в Firefox?

Якщо ви до останнього моменту перебували в щасливому невіданні про те, що з Firefox 57 Mozilla відключить всі застарілі розширення, то радість оновлення до широко розрекламованого Firefox Quantum у вас швидко могла зійти нанівець.

Див. також: як відновити відключені розширення в старих версіях Firefox (рішення масової проблеми з доповненнями Firefox, яка виникла у користувачів починаючи з травня 2019).

Зрозумівши, що щось не так і заглянувши в менеджер розширень, ви побачите: всіх або багатьох з ваших модулів там більше просто немає. Замість них красується напис: «Щось відсутня? Деякі розширення більше не підтримуються Firefox ».

Клік по посиланню «показати застарілі розширення» відобразить те, що у вас було, але включити розширення не вийде.

Як бачите, у нас список важкий. Сюди тільки з відомих потрапили Tab Mix Plus, Менеджер сесій, FindBar Tweak, FireGestures, Location Bar Enhancer, Tab Groups, Thumbnail Zoom Plus і завантажувач музики VK Universal Downloader. Це лише наші втрати. На практиці Firefox втратив тисячі доповнень.

Користувачеві пропонується або видалити підтримуються розширення або ж «знайти заміну». Зрідка цей механізм спрацьовує.

Наприклад, для Thumbnail Zoom Plus він видає цілком прийнятну альтернативу у вигляді Imagus. Однак набагато частіше видається або щось зовсім невідповідний, або загальний список розширень.

На жаль, включити застарілі розширення в Firefox 57 або вище не можна. Вибір у користувача залишається вельми скромний.

Чи не оновлюйтеся або використовуйте стару версію Firefox

  • Якщо ви ще не оновилися на версію 57 і вище: вимкніть оновлення в налаштуваннях браузера;

Якщо ви ще не оновилися на версію 57 і вище: вимкніть оновлення в налаштуваннях браузера;

  • Якщо оновлення вже сталося, то скачайте і встановіть в іншу папку попередню версію 56 і відразу ж вимкніть в ній автоапдейт;
  • Також можна залишитися на версіях Firefox 52, що відносяться до ESR. Це версії з розширений терміном підтримки. Відключати оновлення тут не потрібно.

ESR збірки примітні тим, що розробники будуть виправляти в них баги і закривати уразливості значно довше, ніж для FF 56 і будь-який інший не ESR-редакції браузера.

Тобто залишатися на Firefox 52 ESR краще, з точки зору безпеки, ніж на 56. Однак є і неприємний момент: з перенесенням профілю FF 56-57 на будь-яку версію молодше 55 можуть виникнути проблеми. Про це Mozilla попереджала безпосередньо під час виходу Firefox 55:

Так що, якщо у вас багато цінної інформації, можливо, краще не ризикувати з переходом на ESR. Якщо ж безпеку вам дорожче, і ви віддасте перевагу в результаті Firefox 52 ESR, то для цієї версії перед першим запуском браузера можна створити новий профіль.

Використовуйте offline-інсталятор для установки нової копії Firefox в окрему папку і не забудьте зняти там опцію, щоб «вогненний лис" не запустився автоматично після інсталяції. Інакше він підхопить ваш поточний профіль. Коли установка буде завершена додайте до з'явився ярлику «-p -no-remote»:

Коли установка буде завершена додайте до з'явився ярлику «-p -no-remote»:

Тоді при кліці по іконці замість запуску браузера спершу стартує менеджер, де і можна буде створити новий окремий профіль для версії 52 ESR. Пізніше ви будете вибирати його кожен раз при кліці по цьому ярлику Firefox.

Застарілі розширення можна включити в Firefox Nightly і Developer Edition?

Намагаючись знайти рішення своєї проблеми, в мережі ви, швидше за все, знайдете інформацію про те, що старі розширення все-таки можна включити в Firefox Nightly і Developer Edition (нестабільні тестові версії браузера). Для цього, мовляв, всього лише треба зайти на спеціальну сторінку about: config і подвійним кліком перевести там параметр extensions.legacy.enabled в значення true.

Втім, не поспішайте радіти чи тим більше вже переходити зі стабільних на тестові, проблемні збірки. Ми перевірили цей спосіб на великій групі розширень і з усього, що ми тестували заробив лише Select like a Boss - крихітне розширення для виділення тексту посеред посилань. Його в нових версіях і так можна замінити на Drag-Select Link Text.

Все інше начебто і включилося, але більшість модулів просто не працювало. Ніяк. У свою чергу, Tab Mix Plus після включення приховав за замовчуванням кнопку створення нової вкладки до того ж зробив неможливим перемикання між табами. Його ми тут же відключили. Можливо, з'явилися й інші проблеми, але далі дивитися ми просто не стали.

Можливо, з'явилися й інші проблеми, але далі дивитися ми просто не стали

До слова, сам параметр extensions.legacy.enabled є і в стабільній версії програми, але, зрозуміло, тут він теж не допомагає.

Ще раз пояснимо: проблема застарілих розширень пов'язана саме з движком браузера, який разюче оновився з виходом версії 57. Ніяких простих рішень щодо їхнього включення тут, на превеликий жаль, точно не буде. У майбутньому такого відбуватися вже не має, так як у Firefox тепер залишаються тільки слабо залежні від зміни версій розширення WebExtension.

Що ж робити зараз?

Шукати альтернативи і ... чекати. Багато з авторів розширень встигли перевести їх на нові «рейки» лише зовсім незадовго до виходу Firefox Quantum . Це стосується, наприклад, Adblock Plus і Greasemonkey. Інші ж розробники ще тільки почали свою роботу.

Наприклад, автори вищезгаданого Tab Mix Plus зараз збирають відгуки про те, які з колишніх функцій в першу чергу реалізовувати в новій (ще не випущеної) версії розширення, яка була б сумісна з Firefox Quantum. Роблять вони це тому що їм доведеться заново написати модуль, який містить десятки тисяч рядків коду.

Безумовно, буде багато і тих розширень, що не перероблять під новий Firefox вже ніколи. Тут лише залишається шукати заміну в наповнюють зараз заново каталозі Mozilla або чекати, коли вона з'явиться, залишаючись на одній з колишніх версій браузера.

Ігор Андрєєв - автор статей для ITRew.ru і Our-Firefox.ru. Захоплений сучасними технологіями, розповідаю про них у своїх текстах)

Сторінка автора - twitter.com

схоже

Чи можливо включити застарілі розширення в Firefox?
Застарілі розширення можна включити в Firefox Nightly і Developer Edition?
Що ж робити зараз?
Що ж робити зараз?
Що ж робити зараз?
Чи можливо включити застарілі розширення в Firefox?
Замість них красується напис: «Щось відсутня?
Застарілі розширення можна включити в Firefox Nightly і Developer Edition?
Що ж робити зараз?
Замість них красується напис: «Щось відсутня?

Новости

Пиротехника своими руками в домашних
Самые лучшие полезные самоделки рунета! Как сделать самому, мастер-классы, фото, чертежи, инструкции, книги, видео. Главная САМОДЕЛКИ Дизайнерские

Все товары для праздника оптом купить
Как сделать правильный выбор в работе, бизнесе и жизни, о котором никогда не придется жалеть. Мы хотим рассказать вам об удивительной и очень простой технике 7 вопросов, которые позволят оценить ситуацию

Как сделать красивую снежинку из бумаги
Красивые бумажные снежинки станут хорошим украшением дома на Новый год. Они создадут в квартире атмосферу белоснежной, зимней сказки. Да и просто занимаясь вырезанием из бумаги снежинок разнообразной

Как сделать из бумаги самолет
 1. Самолеты сделанный по первой и второй схеме являются самыми распространенными. Собирается такое оригами своими руками достаточно быстро, несмотря на это самолет летит достаточно далеко за счет свое

Фольгированные шары с гелием
Для начала давайте разберемся и чего же выполнен фольгированный шар и почему он летает дольше?! Как вы помните, наши латексные шарики достаточно пористые, поэтому их приходится обрабатывать специальным

Аниматоры на детские праздники в Зеленограде
Уж сколько раз твердили миру…Что готовиться ко дню рождения нужно заранее, а не бегать в предпраздничный день угорелой кошкой. Нельзя впихнуть в 24 часа дела, рассчитанные на недели. К празднику нужно

2400 наименований пиротехники
В последние десятилетия наша страна может похвастаться появлением нескольких десятков отечественных производителей, специализирующихся на выпуске пиротехники. Если вы сомневаетесь, какой фейерверк заказать,